|
- [ ] Lazy caching tuple properties:
|
|
- Lazy caching tuple properties:
|
|
- [ ] `Codec.frame_rates`
|
|
- `Codec.frame_rates`
|
|
- [ ] `Codec.audio_rates`
|
|
- `Codec.audio_rates`
|
|
- [ ] `Codec.video_formats`
|
|
- `Codec.video_formats`
|
|
- [ ] `Codec.audio_formats`
|
|
- `Codec.audio_formats`
|
|
- [ ] ...
|
|
- ...
|
|
|
|
|
|
- [ ] Case insensitive enum names.
|
|
- Rename `av.enums` to `av.enum` to match singular name of everything else.
|
|
|
|
- Case insensitive enum names.
|
|
- [ ] Rename `av.enums` to `av.enum` to match singular name of everything else. |
|
- Reason 1: I could turn `AVMediaType` into an enum, and retain the old `stream.type == 'video'`. This could also be done by having that enum have multiple keys for each value.
|
|
\ No newline at end of file |
|
- Reason 2: I don't like the feeling of `frame.side_data.get('MOTION_VECTORS')`. Perhaps `frame.side_data.motion_vectors` is better, or just `frame.motion_vectors`. This speaks to how flags and such are exposed as well. |
|
|
|
\ No newline at end of file |